Scheduled maintenance is in progress, we are preforming high load tests, payment test, and more to ensure working of site and backend. Site and console will remain operational
Posted Aug 12, 2026 - 13:51 UTC
Scheduled
We will be undergoing server maintenance during this time
Posted Aug 10, 2026 - 08:30 UTC
This scheduled maintenance affected: API (console.microbix.in).